Q++Studio XE3 support for various QuarkXPress versions

Navigation:  Appendices >

Q++Studio XE3 support for various QuarkXPress versions

Previous pageReturn to chapter overviewNext page

The recommended version of QuarkXPress to use with the XE3 version of Q++Studio is QuarkXPress 2017 (with the 64-bit version of Windows 7 or Windows 10).

 

Currently (November 2018), the XE3 version of Q++Studio supports QuarkXPress versions 8-9-10-2015-2016-2017-2018. Although versions 8-10 of QuarkXPress are no longer supported by Quark, we will try to maintain the compatibility of Q++Studio XE3 with QuarkXPress versions 8-9-10, for as long as possible (for the most up-to-date information, you can always refer to the What's the latest update of each version of QuarkXPress ? page on the Quark website).

 

QuarkXPress 2018

released

May 16, 2018

 

Minimum version: 2018.0

Latest available version: 2018.1.2

 

Q++Studio versions XE3 and XV4 both fully support QuarkXPress 2018, since its announcement on March 1st, 2018.

 

Introduces the importation of an InDesign IDML file directly from inside QuarkXPress.

All installed fonts are now visible in QuarkXPress as variants such as Thin, Book, Black, Condensed, ..., are now listed in the tool palette.

More details available online: short 5 min presentation video and long 39 min presentation video.

 

Important information about Quark 2018:

According to the announcement by Quark, QuarkXPress 2018 is the last version of Quark which will support Windows 7.

 

QuarkXPress 2017

released
May 24, 2017

 

Minimum version: 2017.01

Recommended version: 2017.21

Latest available version: 2017.24

 

 

Q++Studio has supported QuarkXPress 2017, since its announcement on March 1st, 2017.

 

Version 2017.2.4 back-ports many of the fixes introduced in Quark 2018.

Version 2017.2.1 introduces the possibility of creating a QuarkXPress document by importing an InDesign IDML file directly from inside QuarkXPress (this feature remains in beta until Quark 2018).

Possibility of adding text stroking, and text background shading and text framing to individual text elements.

Fixes an issue with right-aligned fillchar tabs in QuarkXPress 2016.

 

Important information about Quark 2017:

Same hardware requirements and limitations as for QuarkXPress 2016, below.

 

QuarkXPress 2016

released

May 24, 2016

 

Minimum version: 2016.0

Recommended version: 2016.22

Latest available version: 2016.23

 

Quark will no longer support QuarkXPress 2016 after November 30, 2019.

 

Q++Studio has supported QuarkXPress 2016, since its launch on May 24, 2016.

 

The time to start QuarkXPress 2016 is much less than for previous versions, which is a big plus to Q++Studio users who need to start QuarkXPress many times in a given workday.

A lot of improvements in the UI.

Copying of native objects from InDesign and PDF files now works very well as of version 2016.1.

 

Important information about Quark 2016:

Recommended hardware specs: 8GB of RAM and a Quad-Core processor.

QuarkXPress 2016 will not run on 32-bit versions of Windows.

QuarkXPress 2016 will not run on any version of Windows XP.

QuarkXPress 2016 cannot be used to open QuarkXPress files saved using Quark 3-4-5-6 (although Quark has released a free utility to convert files from versions 4-5-6 to version 7).

If Windows 7 issues a message such as "QuarkXPress 2016 has stopped working" when closing QuarkXPress 2016 on Windows 7, then please click on the link QuarkXPress 201x has stopped working and follow the steps described therein.

 

Quark will no longer support QuarkXPress 2016 as of November 30, 2019.

 

QuarkXPress 2015

released

April 28, 2015

 

Minimum version: 2015.1

Recommended version: 2015.1

Last available version: 2015.1

 

Quark will no longer support QuarkXPress 2015 after November 30, 2018.

Q++Studio has supported QuarkXPress 2015 since its release on April 28, 2015.

 

New features:

QuarkXPress 2015 is a native 64-bit application.

Work environment under Windows is docked as was introduced under QuarkXPress 10 on the Macintosh.

 

Important information about Quark 2015:

Recommended hardware specs: 8GB of RAM and a Quad-Core processor.

QuarkXPress 2015 will not run on 32-bit versions of Windows.

QuarkXPress 2015 will not run on any version of Windows XP.

QuarkXPress 2015 cannot be used to open QuarkXPress files saved using Quark 3-4-5-6 (although Quark has released a free utility to convert files from versions 4-5-6 to version 7).

If Windows 7 issues a message such as "QuarkXPress 2015 has stopped working" when closing QuarkXPress 2015 on Windows 7, then please click on the link QuarkXPress 201x has stopped working and follow the steps described therein.

 

Quark will no longer support QuarkXPress 2015 as of November 30, 2018.

 

QuarkXPress 10

 

Minimum version: 10.2.

Recommended version: 10.5.

Last available version: 10.52.

QuarkXPress version 10 has been relatively problem-free beginning with version 10.00, although early builds did show extreme slowness when scrolling pages (this now seems fixed in version 10.5).

 

Q++Studio officially supports QuarkXPress 10 since November, 2013.

 

New features:

Textboxes which contain missing fonts are highlighted (this default behavior can be turned off, but we personally find it a big plus).

Starting with version 10.1, it is now possible to zoom at a factor of 8000% (eight thousand percent), a welcome feature for all those frustrated by the previous zoom limitations of previous versions of QuarkXPress.

Starting with Quark 10.5 the bitmap previews generated during scanning are immeasurably nicer.

 

Important information about Quark 10:

 

QuarkXPress 10 will not run on Windows XP.

QuarkXPress 10 cannot be used to open QuarkXPress files saved using Quark 3-4-5-6 (although Quark has released a free utility to convert files from versions 4-5-6 to version 7).

The QuarkXPress file format has changed between Quark 10.1x and 10.2 (similarly to what happened between Quark 9.0x and 9.1). This means that, if you are using Quark 10, you will have to upgrade to Quark 10.2.

 

QuarkXPress 10 is no longer supported by Quark since July 31, 2017.

 

QuarkXPress 9

Minimum version: 9.20.

Recommended version: 9.51.

Last available version: 9.541.

 

QuarkXPress version 9 has been an excellent, problem-free, version from version 9.00. However, in late 2011 the file format and internals of QuarkXPress 9.1 were changed with the result that the minimal version of QuarkXPress 9 is 9.20.  QuarkXPress 9 is no longer supported by Quark since September 30, 2015.

 

QuarkXPress 8

Minimum version: 8.16.

Recommended version: 8.51.

Last available version: 8.51.

(not compatible with Windows 10+)

QuarkXPress version 8 has been an excellent, problem-free, version from version 8.00, however the internal headers of QuarkXPress 8 were changed with version 8.16 which mandates the use of QuarkXPress 8.16 at least.  QuarkXPress 8 is no longer supported by Quark since December 31, 2013, and will not run on Windows 10 or above.

 

QuarkXPress 7

Minimum version: 7.31.

Recommended version: 7.31.

Last available version: 7.5.

(not compatible with Windows 7+)

QuarkXPress version 7 was the first version to support Unicode transparently (previously there were versions that could do one language, such as Korean, but not others, such as Chinese, and vice-versa). A bug was introduced in version 7.3 which make the use of Xpress Tags impossible in many cases and therefore version 7.31 is necessary. Version 7 is a slow version to use in conjunction with Q++Studio due to the extremely long time it takes to start-up.  QuarkXPress 7 is no longer supported by Quark and can only run on Windows XP.

 

QuarkXPress 6

Minimum version: 6.5.

Recommended version: 6.5.

Last available version: 6.52.

(not compatible with Windows 7+)

QuarkXPress 6.0 was eagerly awaited by the Macintosh community because of its support for Mac OSX. QuarkXPress 6 introduced the concept of mandatory software activation to be able to make your copy of QuarkXPress 6 function. Version 6 has had many problems if one opened a file created with a different language version of QuarkXPress.  QuarkXPress 6 is no longer supported by Quark and can only run on Windows XP.

 

QuarkXPress 5

Minimum version: 5.01.

Recommended version: 5.01.

Last available version: 5.01.

(not compatible with Windows 7+)

QuarkXPress 5 followed QuarkXPress late in 2001, but never got adopted by the majority of users of QuarkXPress 4. This version was quite stable from the beginning, but some users have reported problems with documents with over 400 pages using version 5.00, and therefore the recommended version is 5.01.  QuarkXPress 5 is no longer supported by Quark and can only run on Windows XP.

 

QuarkXPress 4

Minimum version: 4.04.

Recommended version: 4.1.

Last available version: 4.11.

(not compatible with Windows 7+)

QuarkXPress 4 was the first 32-bit version of QuarkXPress on the Windows platform. Its main advantages are speed and low memory consumption compared to later versions of QuarkXPress, but its main drawback is the use of an HASP hardware dongle which regularly fails, requiring a reboot and sometimes the purchase of a new dongle.  QuarkXPress 4 is no longer supported by Quark and can only run on Windows XP.

 

QuarkXPress 3

Minimum version: 3.32.

Recommended version: 3.32.

Last available version: 3.32.

Development of the QuarkXPress 3 Xtension used by Q++Studio was stopped in May of 2000 and no further development is planned. QuarkXPress 3 is no longer supported by Quark and can only be used with the legacy ANSI version of Q++Studio whose support ended on December 31, 2014.

 

Versions 3-9 of QuarkXPress are no longer supported by Quark. We will try to continue to offer support for versions 4 to 9, for as long as possible.


Topic 176380 updated on 09-Nov-2018.
Topic URL: https://www.qppstudio.net/webhelp_xe3/index.html?quarkversionsdifferences.htm